Projekt

Allgemein

Profil

Bug #17

HBCI Abruf von Kontostand klappt seit Ubuntu Update (auf 18.04) bei Commerzbank nicht mehr

Von HartmutG vor 6 Monaten hinzugefügt. Vor 3 Monaten aktualisiert.

Status:
Feedback
Priorität:
Normal
Zugewiesen an:
-
Zielversion:
-
Beginn:
24.09.2018
Abgabedatum:
% erledigt:

0%


Beschreibung

Ich nutze seit vielen Jahren GnuCash mit dem HBCI-Plugin unter Linux. Seit meinem Update von Ubuntu 16.04 auf 18.04 vor einigen Wochen geht leider eine Funktion nicht mehr, die vorher jahrelang ging. Es folgen Details:

aktuelle von mir genutzte Versionen (jeweils aus den offiziellen Ubuntu Repositories) unter Ubuntu 18.04:
  • GnuCash: 1:2.6.19-1
  • aqbanking-tools: 5.7.8-1
  • libaqhbci24: 5.7.8-1
Folgende vier Aktionen nutze ich schon seit mehr als 6 Jahren unverändert via HBCI:
  • A) Kontobewegungen abrufen via HBCI bei Commerzbank (ehem. Dresdner Bank)
  • B) Kontostand abrufen via HBCI bei Commerzbank (ehem. Dresdner Bank)
  • C) Kontobewegungen abrufen via HbCI bei Postbank
  • D) Kontostand abrufen via HBCI bei Postbank

Alle vier Aktionen klappten gut mit dem GnuCash und AqBanking, das bei Ubuntu 16.04 dabei war (Versionsnummern habe ich leider nicht mehr zur Hand.) Nach dem Update auf Ubuntu 18.04 (mit den jetzt aktuellen Versionnummern, die ich oben aufgelistet habe) klappen die Aktionen A, C und D immer noch. Doch bei der Aktion B (Kontostand bei Commerzbank) erhalte ich nun immer die Fehlermeldung "Fehler beim Ausführen des Auftrags. Status: error - Job contains errors".

Ich würde das Programm gerne weiterbenutzen, daher die Frage: Mache ich etwas falsch (wenn es auch identisch ist zu den Jahren zuvor), oder kann man am Programm hier etwas korrigieren? Bei Bedarf kann ich gerne weitergehende Informationen zur Verfügung stellen. Vielen Dank schonmal.

Es folgt noch der komplette Konsolen-Text des Kontostand-Abrufs:
-----------------
AqBanking v5.7.8.0stable
Sende Aufträge an die Bank(en)
Exklusiver Zugriff auf Benutzer
Exklusiver Zugriff auf Benutzer 8021070603
HBCI-Aufträge werden ausgeführt
AqHBCI gestartet
Verbindungsaufbau zur Bank...
Hostname "hbci.commerzbank.de" wird aufgelöst...
IP-Adresse ist "212.149.50.147"
Verbindung zu "hbci.commerzbank.de" wird aufgebaut
Verbunden mit "hbci.commerzbank.de"
Verbunden.
Öffne Dialog mit dem Server
Aufträge werden kodiert
WARNING: Your keyfile is accessible ny every user on your computer!
Nobody but you should have access to the file.
WARNING: Your keyfile is accessible ny every user on your computer!
Nobody but you should have access to the file.
Aufträge werden gesendet
Warte auf Antwort
Antwort erhalten
HBCI: 0010 - Nachricht entgegengenommen (M)
HBCI: 0020 - Informationen fehlerfrei entgegengenommen (S)
Aufträge werden kodiert
WARNING: Your keyfile is accessible ny every user on your computer!
Nobody but you should have access to the file.
Aufträge werden gesendet
Warte auf Antwort
Antwort erhalten
HBCI: 9050 - Teilweise fehlerhaft (M)
HBCI: 9210 - Inhaltlich ungültig, Segment/Auftrag wird abgelehnt (S)
Beende Dialog mit dem Server
Aufträge werden kodiert
WARNING: Your keyfile is accessible ny every user on your computer!
Nobody but you should have access to the file.
Aufträge werden gesendet
Warte auf Antwort
Antwort erhalten
HBCI: 0010 - Nachricht entgegengenommen (M)
HBCI: 0100 - Dialog beendet (M)
Verbindung zur Bank wird beendet...
Beendet.
AqHBCI abgeschlossen.
WARNING: Your keyfile is accessible ny every user on your computer!
Nobody but you should have access to the file.
Nachbehandlung der Aufträge
Auftrag Saldoabruf: Fehler
Module zurücksetzen
------------------------

Historie

#1 Von martin vor 4 Monaten aktualisiert

  • Status wurde von New zu Feedback geändert

Moin,

welche Version wurde denn vorher verwendet?

Gruss
Martin

#2 Von HartmutG vor 4 Monaten aktualisiert

Es hat vorher ca. 4-6 Jahre lang funktioniert. Alles 2 Jahre habe ich dafür ein neues Ubuntu (mit neuen Paket-Versionen) genutzt.
Letzmalig klappt es mit meinem Ubuntu 16.04 (Xenial). Laut [1] hatte ich dort die Version "aqbanking 5.6.4beta" installiert. (Google nannte mir auch noch "libaqhbci22: 5.6.4beta-1".) Sind die anderen Versionsnummern auch von Interesse?

[1] https://repology.org/metapackage/aqbanking/versions

#3 Von Johannes vor 3 Monaten aktualisiert

Beste Grüße in die Runde.

Bei mir lässt sich wie oben beschrieben der Kontostand bei der Commerzbank auch nicht abrufen.
Gnucash 2.6.19 "aus Version c1b5e6c8d+ am 2018-04-09 erstellt"
Linux Mint 19 Tara
"Status: error - job contains errors"
Die Umsätze lassen sich abfragen.
Unter Windows funktioniert alles.

Ich würde mich über Ratschläge freuen.

Besten Dank
Johannes

Auch abrufbar als: Atom PDF