Project

General

Profile

Bug #203

OFX Transaction parser doesn't set a transaction type.

Added by jralls@ceridwen.us 10 days ago. Updated 10 days ago.

Status:
Closed
Priority:
Normal
Category:
-
Start date:
03/21/2020
Due date:
Betriebssystem:
FreeBSD, Linux, MacOSX, Windows
AqBanking-Version:
git master e07f346
Anwendung:
GnuCash
Version der Anwendung:

Description

The causes GnuCash to be unable to import the transactions because AB_ImExporterAccountInfo_GetFirstTransaction(element, AB_Transaction_TypeStatement, 0) finds nothing.

The attached patch sets the transaction type to AB_Transaction_TypeStatement and the subtype to AB_Transaction_SubTypeStandard. The two statements were copied from aqpaypal/provider_getstm.c.

0001-Set-Transaction-type-and-subtype-for-OFX-transaction.patch Magnifier - Patch for setting transaction type. (1.02 KB) jralls@ceridwen.us, 03/21/2020 12:10 AM

History

#1 Updated by martin 10 days ago

  • Status changed from New to Closed

Thanks, applied to git.

Also available in: Atom PDF