Project

General

Profile

Bug #75

Zeichensatzproblem

Added by ipwizard 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Start date:
09/25/2019
Due date:
Betriebssystem:
AqBanking-Version:
Anwendung:
Version der Anwendung:

Description

Ich habe neuerdings (heute erstmalig bemerkt) das Problem, dass mir die Umlaute in KMyMoney falsch dargestellt werden. Ich habe mal die Daten für den letzten funktionierenden Abruf und den ersten fehlgeschlagenen Abruf unten aufgeführt. Die Kodierung von der Bank scheint ISO8859 basiert zu sein. Zuvor hat wohl eine Wandlung in UTF-8 stattgefunden, jedenfalls hat der entsprechende Code in KMyMoney (hier vereinfacht dargestellt)

  QString s;
  p = AB_Transaction_GetPurpose(t);
  if (p && *p) {
    s=QString::fromUtf8(p).trimmed();
  }

sich zwischen den beiden Aufrufen nicht geändert. Hier die entsprechenden Details (die Namen der Logfiles habe ich mal hier aufgenommen, damit ich die leichter wiederfinde, falls jemand noch mehr Details braucht)

Gutfall (20190813-151209-002.log):

Versionen:
gwenhywfar: 4.20.1.0
aqhbci: 5.8.0.0beta

Logzeile
:86:835?20DEU xxxxxxxxx?21Karten-Nr. XXXXXX8433?22Beleg vom 09.08.2019?23f374r Abrechnung August?32TANK MAX xxxxxxxxx

aus Anwendung
DEU xxxxxxxxxKarten-Nr. XXXXXX8433Beleg vom 09.08.2019für Abrechnung August

Schlechtfall (20190918-202625-001.log):

Versionen:
gwenhywfar: 4.99.15.0
aqhbci: 5.99.30.1

Logzeile:
:86:835?20DEU xxxxxxxxx?21Karten-Nr. XXXXXX8433?22Beleg vom 03.09.2019?23f374r Abrechnung September?32TANK MAX xxxxxxxxx

aus Anwendung
DEU xxxxxxxxx Karten-Nr. XXXXXX8433 Beleg vom 03.09.2019 f�r Abrechnung September

History

#1 Updated by ipwizard 11 months ago

  • Subject changed from Zeichsatzproblem to Zeichensatzproblem

#2 Updated by martin 11 months ago

  • Status changed from New to Resolved

Fixed in GTI.

#3 Updated by ipwizard 11 months ago

  • Status changed from Resolved to Closed

Fix behebt das Problem. Muchas gracias.

Also available in: Atom PDF