Project

General

Profile

Bug #69

Windows build failure caused by merging plugins/backends into libaqbanking

Added by rhabacker over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
High
Category:
-
Start date:
09/23/2019
Due date:
Betriebssystem:
AqBanking-Version:
Anwendung:
Version der Anwendung:

Description

Building aqbanking from git master (and release 5.99.33beta) for Windows fails at libaqbanking.dll because of missing symbols. From the appended log:

[ 236s] libtool: link: i686-w64-mingw32-gcc -shared .libs/dummy.o -Wl,--whole-archive aqbanking/.libs/libaqbanking_base.a plugins/.libs/libabplugins.a -Wl,--no-whole-archive -L/usr/i686-w64-mingw32/sys-root/mingw/lib -lgwenhywfar -lgmp -lintl -O2 -mms-bitfields -Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -Wl,--no-keep-memory -mwindows -o .libs/libaqbanking-43.dll -Wl,--enable-auto-image-base -Xlinker --out-implib -Xlinker .libs/libaqbanking.dll.a
[ 237s] /usr/lib64/gcc/i686-w64-mingw32/8.2.0/../../../../i686-w64-mingw32/bin/ld: plugins/.libs/libabplugins.a(account.o): in function `AH_Account_new':
[ 237s] /home/abuild/rpmbuild/BUILD/aqbanking-5.99.859e40ef/src/libs/plugins/backends/aqhbci/banking/account.c:38: undefined reference to `_imp__AB_Account_new'
...

_log.txt Magnifier - obs build log (913 KB) rhabacker, 09/23/2019 08:40 AM

build-maint-2019-09-23-12-14-40.log.txt Magnifier (1.21 MB) rhabacker, 09/24/2019 07:17 AM

fix-windows-build.patch Magnifier (22.2 KB) rhabacker, 09/24/2019 07:54 PM

History

#1 Updated by rhabacker over 1 year ago

Crosscompiling 5.8.1 worked out of the box with the same configuration

#3 Updated by rhabacker over 1 year ago

  • File fix-windows-build.patchMagnifier added
  • Subject changed from Windows build failure caused by refactoring to Windows build failure caused by merging plugins/backends into libaqbanking
  • Priority changed from Normal to High

The issue will be fixed with the appended patch.

#4 Updated by martin over 1 year ago

  • Status changed from New to Resolved

Hi,

again, thanks, applied to GIT/master!

Regards,
Martin

#5 Updated by martin over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF